fyqt.net
当前位置:首页 >> jquEry判断浏览器版本 >>

jquEry判断浏览器版本

可以用 $.browser.msie --在 Microsoft's Internet Explorer 浏览器中返回 true。 $.browser.version --IE测试返回7.0 具体的你可以写个页面alert出来测试一下.

$.browser该属性允许我们检测哪一个Web浏览器正在访问网页,通过浏览器本身返回。它包含四个最流行的浏览器类(在Internet Explorer,Mozilla和Webkit,和Opera)以及每个版本信息标志。 可用的标志有: webkit (从jQuery 1.4开始)safari (不建...

jQuery 从 1.9 版开始,移除了 $.browser 和 $.browser.version , 取而代之的是 $.support 。 在更新的 2.0 版本中,将不再支持 IE 6/7/8。 以后,如果用户需要支持 IE 6/7/8,只能使用 jQuery 1.9。 如果要全面支持 IE,并混合使用 jQuery 1.9...

一句varisChrome=navigator.userAgent.toLowerCase().match(/chrome/)!=null;if(isChrome){alert('Chrome');}

如果只是判断IE版本,没必要动用JQUERY来做,直接可以判断了,,下面是各版本的代码 如果一定要用JQUERY来判断的话,可以用jquery.browser来做。下面是简单粟子。 $(function() {var userAgent = window.navigator.userAgent.toLowerCase(); $.b...

一句 var isChrome = navigator.userAgent.toLowerCase().match(/chrome/) != null; if (isChrome) { alert('Chrome'); }

jquery判断浏览器是否是ie6 if($.browser.msie&&($.browser.version == "6.0")&&!$.support.style){ //IE6 //加载另外的css }

function myBrowser(){ var userAgent = navigator.userAgent; //取得浏览器的userAgent字符串 var isOpera = userAgent.indexOf("Opera") > -1; //判断是否Opera浏览器 var isIE = userAgent.indexOf("compatible") > -1 && userAgent.indexOf(...

jQuery 从 1.9 版开始,移除了 $.browser 和 $.browser.version , 取而代之的是 $.support 。 在更新的 2.0 版本中,将不再支持 IE 6/7/8。 以后,如果用户需要支持 IE 6/7/8,只能使用 jQuery 1.9。 如果要全面支持 IE,并混合使用 jQuery 1.9...

研究一下 window.navigator 这个属性自己写方法。

网站首页 | 网站地图
All rights reserved Powered by www.fyqt.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com